闪电网络首次迎战漏洞,Lightning Labs强调不更新或有丢币风险

2019-09-11

9月11日,据闪电网络开发人员再次确认,闪电网络软件的旧版本存在严重安全漏洞,如果用户不进行更新,可能会导致他们损失资金。

早在8月30日,闪电网络开发者Rusty Russel首次披露了该漏洞,本周三,闪电网络实验室(Lightning Labs)首席技术官Olaoluwa Osuntokun证实了这一点。

目前尚不清楚是否有用户遭遇损失(或者如果有的话,损失有多少),以及受影响的用户又有多少(注:闪电网络的特性之一就是匿名性强)。

Osuntokun在开发者邮件列表中警告称,多个版本的闪电网络节点容易遭受攻击,它们应立即进行更新,其还补充表示:

“我们已经确认了CVE漏洞被滥用的实例。”

截至目前,闪电网络还是一种实验性的二层(layer-2)扩容解决方案,其旨在允许几乎无成本的交易,使得用比特币购买咖啡等日常交易成为可能。

然而,CVE漏洞的存在表明,这种技术仍具有任何代码金融产品所存在的问题。

“在各种闪电网络产品中都发现了安全问题,它们可能会导致用户损失资金,”Russel 在最初的帖子中写道,“全部细节将在4周内(2019-09-27)发布,请在这之前进行升级。”

Osuntokun则强调,闪电网络目前仍处于初级阶段。

据悉,受影响的闪电网络软件,包括所有LND 0.70及以下版本、C-Lightning 0.70及以下版本以及E Clair 0.3及以下版本的客户端。

译者:洒脱喜

文章来源:https://www.8btc.com/article/479096

原文链接:https://www.coindesk.com/lightning-network-developers-warn-of-bug-that-could-cause-loss-of-bitcoin

原文作者:William Foxley

推荐阅读: